Issues Accessing TeamForm (resolved)
Incident Report for TeamForm - Service Status
Resolved
This incident has been resolved.
Posted Feb 06, 2024 - 20:22 AEDT
Monitoring
We have implemented the fix and are now monitoring for any further issues.
Posted Feb 06, 2024 - 20:09 AEDT
Identified
We have identified the cause and are progressively rolling out a fix.
Posted Feb 06, 2024 - 20:05 AEDT
Investigating
We are currently investigating reports that some users cannot access TeamForm.
Users see "Couldn't complete that action".
Posted Feb 06, 2024 - 19:57 AEDT