Operational issue in US East - no further impact

Incident Report for TeamForm - Service

Resolved

This incident has been resolved.
Posted May 08, 2026 - 14:41 AEST

Update

Services are no longer impacted - TeamForm will monitor.
Posted May 08, 2026 - 12:56 AEST

Update

We are continuing to investigate this issue.
Posted May 08, 2026 - 11:10 AEST

Investigating

TeamForm is currently investigating an operational issue impacting Elastic Compute Cloud (N. Virginia).
Posted May 08, 2026 - 11:10 AEST