TeamForm has implemented a fix to authentication issues

Incident Report for TeamForm - Service

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 08:58 AEST

Monitoring

Users are now able to authenticate.

Please return to your TeamForm sign in page and log in.
Posted Jun 27, 2025 - 08:51 AEST

Investigating

Some users are seeing an error when trying to access TeamForm
Posted Jun 27, 2025 - 08:30 AEST