Issue with streamlined authentication for Single Sign On

Incident Report for TeamForm - Service

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 16:29 AEDT

Update

TeamForm has implemented a fix.
Posted Mar 24, 2026 - 16:28 AEDT

Investigating

TeamForm is investigating an issue with streamlined authentication via Single Sign On.
Users should try entering their email address at the sign in page.
Posted Mar 24, 2026 - 16:15 AEDT