Isolated performance degredation
Incident Report for TeamForm - Service Status
Resolved
This incident has been resolved and root cause identified.
Posted Feb 28, 2024 - 16:59 AEDT
Investigating
We are currently investigating a performance issue isolated to a limited set of customers.
Posted Feb 28, 2024 - 15:54 AEDT