TeamForm has resolved authentication issues

Incident Report for TeamForm - Service

Resolved

This incident is resolved
Posted Jun 27, 2025 - 12:49 AEST

Update

A further fix has been implemented and users are successfully authenticating.
Posted Jun 27, 2025 - 12:37 AEST

Monitoring

A fix has been implemented and users are successfully authenticating. We are monitoring.
Posted Jun 27, 2025 - 10:27 AEST

Investigating

Some users are seeing an error when trying to access TeamForm
Posted Jun 27, 2025 - 09:25 AEST